PHPEclipse

Eclipse v3.2 and PHPEclipse v1.1.9 (latest) combination does not work in Ubuntu (intrepid ibex).
You will have to use the previous PHPEclipse version which is v1.1.8.
Find it on the sourceforge download page.

Special note for ubuntu users: remove the openjdk and gij packages and then apt-get sun-java6-jdk !